sv_use_steam_voice 0?

Report hackers, annoyers, crashes, problems here.

sv_use_steam_voice 0?

Postby ciaphas » Tue May 29, 2012 1:09 am

Hey all. Was playing on Westbox much of this weekend, and haven't been able to talk on voice without either A) sounding terrible or B) blackholing everyone else's audio completely. I did some diagnosis and found out it's because sv_use_steam_voice is set to 0 in the server config.

As far as I can tell, leaving it at 0 only serves the purpose of allowing HLSS micspam, while killing the mics of several users. Was it your intent to leave this at 0 to allow for HLSS?
ciaphas
 
Posts: 3
Joined: Tue May 29, 2012 1:05 am

Re: sv_use_steam_voice 0?

Postby fingerman » Tue May 29, 2012 6:02 am

My mic has worked well since 2007.
Image
User avatar
fingerman
Red Admin
Author of: The Pushers Guide to Little Carts
 
Posts: 1480
Joined: Wed Oct 13, 2010 7:08 pm

Re: sv_use_steam_voice 0?

Postby MamaWeegee » Tue May 29, 2012 9:47 am

fingerman wrote:My mic has worked well since 2007.


Mine has since when i got it :O
Level 12 Cardinals Fan
User avatar
MamaWeegee
 
Posts: 165
Joined: Fri Feb 24, 2012 1:17 am

Re: sv_use_steam_voice 0?

Postby Failhorse » Tue May 29, 2012 10:36 am

This isn't for HLDJ. And if your microphone worked before Valve changed the codec, I suggest you check your printer cable.


sv_use_steam_voice 0 = Low quality, small performance overhead, high compatibility.
sv_use_steam_voice 1 = High quality, large performance overhead, medium/low compatibility.
Image
User avatar
Failhorse
Red Admin
 
Posts: 2171
Joined: Sun Oct 10, 2010 8:50 pm
Location: Chicago USA

Re: sv_use_steam_voice 0?

Postby ciaphas » Tue May 29, 2012 12:11 pm

Didn't know there was much in the way of other differences, thanks. Rather ironic that sv_use_steam_voice 0 is 'high' compatibility when it definitely breaks my mic, though (I just tested on a quick local server) Wish I knew WHY it breaks, but it's very consistent.

Does anyone know anything about what underlying codecs the two options use?
ciaphas
 
Posts: 3
Joined: Tue May 29, 2012 1:05 am

Re: sv_use_steam_voice 0?

Postby rabi » Thu Dec 05, 2013 1:25 am

The CSN TF2 servers are great, have a good community and westbox has a low ping to my location, but there is a small problem. I'm running linux, and the native platform only supports steam's "new" voice codec. This is a problem since all the CSN servers I've checked are running with cvar sv_use_steam_voice set to 0. While this topic has been discussed before the relevance of the thread is not in this context.
testking world testking world
85% off Buy Now certkiller PMI-001
Testking http://testking.info
640-864 questions 640-864 questions
rabi
 
Posts: 1
Joined: Thu Dec 05, 2013 1:09 am

Re: sv_use_steam_voice 0?

Postby Nathan173AB » Mon Aug 11, 2014 8:57 pm

rabi wrote:The CSN TF2 servers are great, have a good community and westbox has a low ping to my location, but there is a small problem. I'm running linux, and the native platform only supports steam's "new" voice codec. This is a problem since all the CSN servers I've checked are running with cvar sv_use_steam_voice set to 0. While this topic has been discussed before the relevance of the thread is not in this context.

I also use Linux. Could this be why I'm unable to voice chat in CSN servers but I can in other servers? It's frustrating sometimes not being able to talk in them. :-(
Nathan173AB
 
Posts: 4
Joined: Mon Aug 11, 2014 8:49 pm

Re: sv_use_steam_voice 0?

Postby Nathan173AB » Wed Mar 25, 2015 12:58 pm

Will there be any consideration of this issue again? From what information I can find, people who have trouble talking in servers with sv_use_steam_voice set to 1 should be able to easily fix the issue by setting up their mic properly with Steam voice chat, which is a lot more straightforward than what us Linux and Mac users would have to do to be able to talk while it's set to 0.

Please reconsider.
Nathan173AB
 
Posts: 4
Joined: Mon Aug 11, 2014 8:49 pm

Re: sv_use_steam_voice 0?

Postby fingerman » Wed Mar 25, 2015 9:03 pm

I will change it and we can test it.
Image
User avatar
fingerman
Red Admin
Author of: The Pushers Guide to Little Carts
 
Posts: 1480
Joined: Wed Oct 13, 2010 7:08 pm

Re: sv_use_steam_voice 0?

Postby Nathan173AB » Thu Mar 26, 2015 2:16 pm

Thanks for this! :D I hope it works out well.
Nathan173AB
 
Posts: 4
Joined: Mon Aug 11, 2014 8:49 pm


Return to Server Support

Who is online

Users browsing this forum: No registered users and 1 guest